Chia sẻ bộ khống chế nhiệt độ

Thảo luận trong 'Họ 8051'

Đang xem chủ đề này ( Thành viên: 0, Khách: 0)

  1. thai duong

    thai duong Học sinh trung cấp

    Tham gia ngày:
    2/12/14
    Bài viết:
    85
    Đã được thích:
    20
    Điểm thành tích:
    8
    Giới tính:
    Nam
    Chào bạn tmd.
    mình mới làm mạch thật (chưa có con24c04) chưa thấy đọc nhiệt độ được vẫn 85oc nhưng chỉnh start và stop vẫn bình thường, ko biết bị gì nhờ bạn tmd coi giùm mình với, còn 18b20 mình lấy từ đồng hồ vạn niên đang chạy nên con này còn tốt. mà con I2C có cần lắp vào mạch thật ko, và chân số 6 có chức năng gì vậy bạn - thấy chân này có tín hiệu, thanks
     
    Last edited: 28/7/15
  2. tdm

    tdm Kỹ sư

    Tham gia ngày:
    1/9/12
    Bài viết:
    459
    Đã được thích:
    428
    Điểm thành tích:
    63
    Giới tính:
    Nam
    tdm sẽ xem lại rồi trả lời cho bạn sau.
     
    thai duong thích bài này.
  3. thai duong

    thai duong Học sinh trung cấp

    Tham gia ngày:
    2/12/14
    Bài viết:
    85
    Đã được thích:
    20
    Điểm thành tích:
    8
    Giới tính:
    Nam
    Bạn tdm kiểm tra giúp mình chưa.
     
  4. tdm

    tdm Kỹ sư

    Tham gia ngày:
    1/9/12
    Bài viết:
    459
    Đã được thích:
    428
    Điểm thành tích:
    63
    Giới tính:
    Nam
    file này đã chạy trên mạch thực tế.
     

    Các file đính kèm:

    preda_0078 thích bài này.
  5. thai duong

    thai duong Học sinh trung cấp

    Tham gia ngày:
    2/12/14
    Bài viết:
    85
    Đã được thích:
    20
    Điểm thành tích:
    8
    Giới tính:
    Nam
    Cám ơn bạn đã sửa code và đã chạy tốt, nhưng mạch này hay bị treo quá, mình đang test cho nhiệt độ lên cao 1,2 lần là bị treo luôn phải reset lại rồi mới chạy được, bạn k.tra được phần này ko, thanks bạn.
     
  6. tdm

    tdm Kỹ sư

    Tham gia ngày:
    1/9/12
    Bài viết:
    459
    Đã được thích:
    428
    Điểm thành tích:
    63
    Giới tính:
    Nam
    trạng thái treo như thế nào? Nếu dùng relay đóng tải lắp thêm diot // với cuộn hút, thêm tụ 104 lọc nguồn cho MCU.
     
  7. thai duong

    thai duong Học sinh trung cấp

    Tham gia ngày:
    2/12/14
    Bài viết:
    85
    Đã được thích:
    20
    Điểm thành tích:
    8
    Giới tính:
    Nam
    mình chỉ kích con A1015 để cấp mức 1 cho 2 con IC555 để phát ra còi hú cảnh báo thôi và cũng lắp tụ 104 trong con MCU rồi, cũng treo đ.trở 10K tại chân start rồi cũng bị treo, bạn xem lại giùm mình nha, thanks bạn. còn đây là video lỗi hay bị treo..
     
  8. tdm

    tdm Kỹ sư

    Tham gia ngày:
    1/9/12
    Bài viết:
    459
    Đã được thích:
    428
    Điểm thành tích:
    63
    Giới tính:
    Nam
    Tdm làm mạch thật các led sáng đều không bị như bạn. Trở treo cho 18b20 bạn dùng bao nhiêu? (Tdm dùng 4.7k) Bạn thử cho chạy không tải xem sao.(bỏ thử phần kết nối với loa)
     
  9. thai duong

    thai duong Học sinh trung cấp

    Tham gia ngày:
    2/12/14
    Bài viết:
    85
    Đã được thích:
    20
    Điểm thành tích:
    8
    Giới tính:
    Nam
    mình cũng dùng 4k7 tại 18b20 và bỏ hết ko tải cũng bị vậy bạn ah, và mình thử lại trong mô phỏng cũng bị y chang như mạch thật, chạy được khoảng 1 phút là bị treo luôn. bạn k.tra lại giùm mình nha, thanks.
     
    hoahongnhung thích bài này.
  10. hoahongnhung

    hoahongnhung Học sinh phổ thông

    Tham gia ngày:
    3/8/15
    Bài viết:
    13
    Đã được thích:
    1
    Điểm thành tích:
    3
    Giới tính:
    Nam
    chào các anh ! em là hoc sinh ạ , em cũng đang lắp thử mạch của anh tdm , vì em thấy mạch này có thể ứng dụng tốt vào thực tế, khi cắm điện vào chạy thử em thấy hiện trạng cũng y trang như của anh thai duong ạ ! led ở hàng chục temp 1 sáng hơn hẳn các số khác,em lắp con 24c04 vào nó không nhớ được các thiết lập trước lúc mất điện các anh ạ !em cảm ơn các anh .Mạch của em đây ạ :
     

    Các file đính kèm:

    Last edited: 3/8/15

Chia sẻ trang này