Cần giúp Lỗi Keli c V5

huunho

Thạc sỹ
#1
Chào mọi người.
Mình mới mua kít stm32F072B rồi cài đặt pack cho keli c v5, tải thư viện cho cubemx xong rồi, biên dịch thì ok , nạp vào thì báo lỗi ko nạp dc, lúc mới mở proj lên thì có lỗi này. ai gặp rồi chỉ mình với:
loi keli c.png
 

huunho

Thạc sỹ
#2
cửa sổ output báo lỗi như sau:

File : C:\Keil_v5\ARM\PACK\Keil\STM32F0xx_DFP\2.0.0\Keil.STM32F0xx_DFP.pdsc
Sequence : CheckID
Context : Item #1: <control if="jep106id != 0x20">
Item #0: <block>::Line 2
Expression : " Message(2, "Not a genuine ST Device! Abort connection.");"
----------------------------^
E203 : Undefined identifier - function 'Message'
 
#3
lúc mở lên lỗi thì hiện em cũng bị chưa biết sao. Còn nạp không được có nhiều lý do lắm
ấn Reset mới nạp được thì do chưa tích SYS debug seribus
hoặc chưa chọn ST-Linkdebuger
hoặc cọn st-Linkdebuger mà chưa add chip trong phần setting
 
#4
lúc mở lên lỗi thì hiện em cũng bị chưa biết sao. Còn nạp không được có nhiều lý do lắm
ấn Reset mới nạp được thì do chưa tích SYS debug seribus
hoặc chưa chọn ST-Linkdebuger
hoặc cọn st-Linkdebuger mà chưa add chip trong phần setting
 
#5
lúc mở lên lỗi thì hiện em cũng bị chưa biết sao. Còn nạp không được có nhiều lý do lắm
ấn Reset mới nạp được thì do chưa tích SYS debug seribus
hoặc chưa chọn ST-Linkdebuger
hoặc cọn st-Linkdebuger mà chưa add chip trong phần setting
 

huunho

Thạc sỹ
#6
nó lỗi do keli c không nhận chíp F072 trong thư viện mặc dù cài đủ rồi, nếu bạn gặp rồi thì vào team view sửa giúp. STM32 ST-LINK Utility đã nhận kít và nạp ok
 
#7
nó lỗi do keli c không nhận chíp F072 trong thư viện mặc dù cài đủ rồi, nếu bạn gặp rồi thì vào team view sửa giúp. STM32 ST-LINK Utility đã nhận kít và nạp ok
Em update lại phần mềm lên phiên bản cao nhất CMSIS CMSIS Driver, Keil ở phần Device Specifi là hết anh ơi, tạo mới project ko còn hiện tượng này nữa.
 

Quảng cáo Google